Degraded performance of market data

Incident Report for getquin

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 20:09 UTC

Investigating

We are currently investigating this issue.
Posted Apr 01, 2025 - 19:17 UTC
This incident affected: Portfolio Tracking and Markets.