The issue affecting market data updates has been resolved. Prices on portfolio and asset pages should now be updating normally again.
Posted Apr 24, 2026 - 09:41 UTC
Investigating
We are currently investigating an issue that may cause prices for some assets in the app, including on portfolio and asset pages, to appear missing or outdated. Our team is working to restore normal updates as quickly as possible.
Posted Apr 21, 2026 - 09:10 UTC
This incident affected: Portfolio Tracking and Markets.