BTC intraday pricing has been restored after our external data provider resolved the issue with the BTC. Price updates and intraday charts are now operating normally.
Posted Jul 08, 2026 - 07:15 UTC
Identified
We are currently experiencing an issue with BTC intraday pricing due to a disruption on our external data provider’s side. At this time, the issue appears to affect only BTC pricing. Other assets and pricing data remain operational.
Posted Jul 07, 2026 - 10:19 UTC
This incident affected: Portfolio Tracking and Markets.