Flanks Web Form – Availability Issue

Incident Report for getquin

Resolved

The issue affecting the Flanks web form has been resolved following a recent fix deployment. Users should now be able to access and load the form normally without errors. We are continuing to monitor the system to ensure stability.
Posted Mar 27, 2026 - 09:21 UTC

Investigating

Users are currently experiencing issues when attempting to load the Flanks web form. The page may fail to load, time out, or display errors, preventing normal usage. The issue appears to be affecting multiple users and is under investigation.
Posted Mar 27, 2026 - 08:19 UTC
This incident affected: Bank Connections (Europe).