Security Upgrade in Progress

Incident Report for getquin

Resolved

Our scheduled security enhancement has been successfully completed. All systems are fully operational. Thank you for your patience.
Posted Apr 02, 2026 - 07:36 UTC

Monitoring

We're performing a scheduled security enhancement to improve data protection. Cash transaction details may be temporarily unavailable. We expect to complete this shortly - thank you for your patience.
Posted Apr 01, 2026 - 21:33 UTC
This incident affected: Portfolio Tracking.